Victory Riders Network

The online community for riders & enthusiasts of Victory Motorcycles

So first off let me say I love my bike, it puts a smile on my face every day, also pleased with my choice to choose the Victory brand as there just awesome machines.

As some know I've been building this bike for close to two and a half years now (it's been a nightmare from start to finish) anyway as of a few days ago all I'm waiting for is the seat from the trimmers every thing else is finished.

So lets go back a week to Mother's Day, I decide to take the bike off the hoist to give it a wash, once I rolled it out I took a look at it and thought you know I could ride this thing so I grab my helmet put my untrimmed seat pan on with a couple of towels and off I go, nearly two and a half years I haven't ridden my bike so I was like a fat kid in a lollie shop, first thoughts insane power handles pretty good for a big rake and big wheel, air ride pretty good to and all seems good FINALLY only fault I found was the indicator warning light on the dash wasn't working, but all indicators were working fine as was the hazards, so I thought must be a globe.

So on the weekend I decide to take a look at this globe, pull the panel off and check globe and its fine and I swapped it with a working one to be sure, checked the globe socket for power using a multimeter no power, check earth yes earth is good, so I think maybe something in the head light has unplugged, pulled that apart and it all looked fine, there is two plugs in the head light supply power to the dash lights so I unplugged them and checked the dash looms from the globe socket to the plugs in the light using my multimeter on continuity and they all tested okay.

So now I'm thinking I've done something wrong in the tail light plug as I just wired it up a few days earlier, first I unplugged it and still on joy so I check the wiring and double, triple check it and I sure that's not the problem, there's only six wires and there not hard to work out whats what. So now I think some research is in order, after spending god knows how long searching forum after forum I found a wiring diagram.

Now armed with the wiring diagram the search begins, let me say the wiring is pretty complex and impressive at the same time on these bikes and I'm no electrician by any means. I'll just add I learnt a lot of things that I didn't know the bike had or the way they worked. So after picking my brains out I worked out that everything goes through the ECM except the indicator warning light, the warning light output comes from the flasher module so I find it and work out it's the blue/violet wire that should have power when both indicators and hazards are on so I test it and there's power there .

Now I know that's the wire with my meter I check for continuity from the flasher module to the plug in the head light (same colour wire at the plug) and there's no continuity, so now I'm thinking is the wire broken, so back at the indicator module I start removing the sticky tape to expose the wiring loom as far as I could until it heads under the fuel tank, check it again from module to just before it goes under tank and there's continuity there, couldn't check loom at the front of tank so no option but to pull the tank off.

So I remove the tank being careful not to damage my new paint work, once it moved the hole loom is easy to get too, I continue to remove all the protection tape on the loom to expose the wires, now I notice the chassis loom has been cut and extended all with black wires . I found my blue violet wire and test it for continuity from module to the first cut and join both side of it and it's fine so I continue to the other end of the join on the black side it's good then check the blue/violet end and nothing, I think thank Christ I found the problem.

I remove the heat shrink to find the solder had come off, now here's my problem.

This is were my huge thank you to Melbourne Victory comes in.

Let me say first off the wires were NOT twisted together, they were just put end to end touching each other by the looks of it with a blob of solder and it looks as if they didn't even heat the solder up enough to melt it, now as I said I'm no expert but I've done my fair share of soldering and that's not how you solder, a couple of things I was taught was use the right type of solder, after it's done it should be shinny not dull looking, twist the wires together and melt the solder between the wiring.

Now looking at the rest of the joins they look like they have this blob of shit rather than a proper join, so who knows how much grief this will cause me in the future or leave me stranded in the middle of nowhere, and let me tell you there's anywhere between 80-100 joins, so what do I do. Take it back, well with all the issues I've had with the lack of quality workmanship coming out of that store I have ZERO confidence in them and to be honest I don't want them touching my bike, hell I wouldn't give them my whipper snipper to work on, sorry but true. Then there's the $1200 they charged me for labour and that pisses me off.

So here it is thank you Melbourne Victory for cutting my perfect wiring loom and turning it into an unreliable bike that's an accident waiting to happen , and how dare you even let the bike out of the workshop like that. Thank you for making me pull my bike apart again as if it hasn't been apart for long enough. Thank you for wasting a good 8 hours of my time to find your mistake. And thank you very much for taking my hard earned money $1200 in labour and delivering that pathetic work.

And to Peter A or any management that reads this I'd be more than happy to discuss this over the phone with you because what you have read is a small piece of the pie, still plenty to get off the chest. Or even better pop around for a look for yourself, we'll have a chat over a beer.
You can get my details from your computer as I purchased my bike there, sunset red jackpot 09 IY680

At least things might get better now that Darryl is back and Grant is gone.

I can already see the die hard victory does no wrong supporters/share holder trying to break the words typed in a minute record. ;-) keeping it real........

Views: 763

Attachments:

Reply to This

Replies to This Discussion

Not the best pictures
Attachments:
More
Attachments:
More
Attachments:
Again
Attachments:

That is disappointing to hear Rob, especially after what you’ve invested in the bike, which they know full well.

AS I have previously mentioned, your bike is the best Victory I have EVER seen and the paint job on it is incredible- almost 3D. Kudos to you- you’ve done an amazing job man.

Looking forward to seeing more pictures or a dedicated thread?

Appreciate your comments Kris, yeah I've invested a small fortune in the bike and to say I'm disappointed in them would be a understatement .
Receipt
Attachments:

Shit!!!, mine is in there at the moment being rebuilt, best I keep an eye on them

Just a quick update, I'm happy to announce that I haven't been contacted by anyone from the Melbourne store, no calls or messages through the forum, top job Melbourne Victory

I won't stop until I'm heard.
Hi Rob
Sorry we had not picked up on your issues earlier.
If it works for you I will have the Melbourne dealership contact you Monday morning. If this is not suitable let me know a time that works.
Regards
Peter Harvey
Thank you for your reply Peter, Monday will be fine
Good to see someone is paying attention Rob.
Peter- why does this come from you and not Victory Melbourne? Not good to see.......

RSS

Events

Victory Riders on Facebook







Follow The Victory Riders Network on Twitter



Get notification of the latest activity happening on the Victory Riders Network or any of the model specific sites in one place.
www.twitter.com/vrnetwork

 

Members

© 2020   Created by Victory Riders.   Powered by

Badges  |  Report an Issue  |  Terms of Service