Victory Riders Network

The online community for riders & enthusiasts of Victory Motorcycles

Hi Guys and Gals,

 

Where do i start?

 

Have an 11 JP, stage 1 swept exhausts and additional work all done by the dealer. Bike is just over two weeks old with a little over 400kms on it. Perfect, right? Nup.

 

Started it the other (cold) morning to get to work to pay for it, and all the way it was either missing or hunting. It pops and crackles out the exhaust. The day before, there were no such issues at all after a good ride out to the lake and back.

 

Thought i might have a bad tank of fuel, so with the tank nearly empty, filled it up with premium and thought it was getting better. But today it was the same. Went for a blast again, and after a decent ride, no more dramas, so im thinking of ruling out the bad fuel idea.

 

Why is it good after getting hot, and not when its cold? Could it be a tuning problem with the colder air temps?

 

Another issue is that the gearbox seems to have a hell of a lot of play in it. When rolling off the throttle, there seems to be a flat spot in the throttle when going to power on again, then wham with the box. All gears are the same, but this isnt noticable as much when cold, more so when hot. Do they use a lighter oil to run them in? Would thicker oil help this box problem?

 

Last is more of a question, (thank god i hear you say). Has anybody got the Guarddawg keyless ignition/alarm fitted to thier bike, and if so, what do you think of them.

 

Thanks all for reading, and hopefully someone out there may be of some assistance.

On a side note, my nearest Vic Dealer is about 1800 kms away, so thought id try here first.

 

Thanks again,

 

Bags

Views: 105

Reply to This

Replies to This Discussion

G'day, I have an 11 Jackpot too, I was told that at least for the first 1000km, it may pop a bit, I am led to believe that the engine management system takes a little while to calibrate the ECU, as they are manunfactured to go into many countries.

Mine is fine and I don't recall having trouble with it. Although I do use the BP 98 Octane fuel where ever I can. I have nearly 3,000 KM on mine and no dramas...

Not sure if this helps..

 

Jason

Thanks Jason.

 

Maybe I'll wait and see how it goes. Just found it odd that one day it was fine, then the next morning it didnt want to play ball. I use shell 98, maybe I will switch to BP as well see how it goes.

 

Cheers

hi Graeme l have a 09 Jackpot when l use Shell fuel it did the the poping thing l use every thing but shell does it stall when you drop down a gear and put some revs in it
Hey Wayne, yep, that sound about right. Sits idling, popping away and dropping RMPs to nearly stall, and a big flat spot when dropping down gears. Thanks, Ill experiment with some BP 98 next time like previous and see how it goes.
Hi Graeme, I have the guarddawg and other than the batteries going flat fairly regularly and getting an updated download it works good , but in saying that I wouldn't have got it fitted if I knew what I do now. Mine has only stayed powered up not dead and can't start like others. My Hammer pops and farts occasionaly and sometimes doesn't respond on throttle blips at idle but this is only fairly rare and may be only in cold weather. Webby.

RSS

Events

Victory Riders on Facebook







Follow The Victory Riders Network on Twitter



Get notification of the latest activity happening on the Victory Riders Network or any of the model specific sites in one place.
www.twitter.com/vrnetwork

 

Members

© 2020   Created by Victory Riders.   Powered by

Badges  |  Report an Issue  |  Terms of Service